home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / dev-util / cvs-1.12.12-r2 / cvs-1.12.12-r2.ebuild < prev    next >
Text File  |  2005-10-16  |  2KB  |  71 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.12-r2.ebuild,v 1.12 2005/09/04 11:00:37 hardave Exp $
  4.  
  5. inherit eutils pam
  6.  
  7. DESCRIPTION="Concurrent Versions System - source code revision control tools"
  8. HOMEPAGE="http://www.cvshome.org/"
  9.  
  10. SRC_URI="http://ccvs.cvshome.org/files/documents/19/872/${P}.tar.bz2
  11.     doc? ( http://ccvs.cvshome.org/files/documents/19/878/cederqvist-${PV}.html.tar.bz2
  12.         http://ccvs.cvshome.org/files/documents/19/881/cederqvist-${PV}.pdf
  13.         http://ccvs.cvshome.org/files/documents/19/880/cederqvist-${PV}.ps )"
  14.  
  15. LICENSE="GPL-2 LGPL-2"
  16. SLOT="0"
  17. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
  18.  
  19. IUSE="crypt doc emacs kerberos pam"
  20.  
  21. DEPEND="virtual/libc
  22.     >=sys-libs/zlib-1.1.4
  23.     kerberos? ( virtual/krb5 )
  24.     pam? ( virtual/pam )"
  25.  
  26. src_unpack() {
  27.     unpack ${P}.tar.bz2
  28.     use doc && unpack cederqvist-${PV}.html.tar.bz2
  29.     EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-1.12.12-cvsbug-tmpfix.patch
  30. }
  31.  
  32. src_compile() {
  33.     econf \
  34.         --with-external-zlib \
  35.         --with-tmpdir=/tmp \
  36.         `use_enable crypt encryption` \
  37.         `use_enable pam` \
  38.         || die
  39.     emake || die "emake failed"
  40. }
  41.  
  42. src_install() {
  43.     einstall || die
  44.  
  45.     insinto /etc/xinetd.d
  46.     newins ${FILESDIR}/cvspserver.xinetd.d cvspserver || die "newins failed"
  47.  
  48.     dodoc BUGS ChangeLog* DEVEL* FAQ HACKING \
  49.         MINOR* NEWS PROJECTS README* TESTS TODO
  50.  
  51.     if use emacs; then
  52.         insinto /usr/share/emacs/site-lisp
  53.         doins cvs-format.el || die "doins failed"
  54.     fi
  55.  
  56.     if use doc; then
  57.         dodoc ${DISTDIR}/cederqvist-${PV}.pdf
  58.         dodoc ${DISTDIR}/cederqvist-${PV}.ps
  59.         tar xjf ${DISTDIR}/cederqvist-${PV}.html.tar.bz2
  60.         dohtml -r cederqvist-${PV}.html/*
  61.         cd ${D}/usr/share/doc/${PF}/html/
  62.         ln -s cvs.html index.html
  63.     fi
  64.  
  65.     newpamd ${FILESDIR}/cvs.pam-include-1.12.12 cvs
  66. }
  67.  
  68. src_test() {
  69.     einfo "FEATURES=\"maketest\" has been disabled for dev-util/cvs"
  70. }
  71.